当前位置: 网站首页 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码:无敌急跌操盘,百万绝品公式,操盘机器人

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、无敌急跌操盘,红买绿卖粉持股灰持币青色观望

{公式名称:无敌急跌操盘}

N:=5;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
操作线:EMA(C,N),COLORWHITE,NODRAW;
MTM:=CLOSE-REF(CLOSE,1);
MA3:=MA(CLOSE,3);
A1A:=EMA(CLOSE, 9);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
DY:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
LC:=REF(CLOSE,1);
A1B:=((A1A - EMA(CLOSE, 5)) < 0);
A1C:=((A1A - EMA(CLOSE, 5)) > 0);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
A:=REF(操作线,1);
A1D:=BARSLAST(A1B);
A1E:=BARSLAST(A1C);
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
A1F:=IF((A1E > 0),(CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,0);
A20:=SUM(A1F,0);
红买:A,COLORRED,NODRAW;
绿卖:HIGH,COLOR00FF00,NODRAW;
粉持股:CLOSE,COLORFF00FF,NODRAW;
灰持币:OPEN,COLORFFFFCC,NODRAW;
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
A21:=IF((A1D > 0),(0 - 2),0);
A22:=IF((A1E > 0),SUM((CLOSE-REF(CLOSE,1))/REF(CLOSE, 1)*100,A1E),0);
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13
OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
A23:=A22 / A1E;
A25:=EMA(EMA(EMA(CLOSE, 3), 3), 3);
STICKLINE(操作线>=A,HIGH,LOW,0,0),COLORFF00FF;
STICKLINE(操作线>=A,OPEN,CLOSE,1,0),COLORFF00FF;
STICKLINE(CROSS(操作线,A),HIGH,LOW,0,0),COLORRED;
红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
离场:=IF(红色持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
多方:((A25 - REF(A25, 1)) + A25)COLOR0000FF,LINETHICK2;
空方:MA(多方, 15)COLORFF49FF;
今离场价:REF(离场,1)COLOR0000FF,NODRAW;
STICKLINE(CROSS(操作线,A),OPEN,CLOSE,1,0),COLORRED;
DRAWICON(CROSS(操作线,A),LOW-0.1,1),COLORRED;
青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
IF(多方>REF(多方,1),多方,DRAWNULL),COLORFFFFCC,LINETHICK4,POINTDOT;
IF(空方>REF(空方,1),空方,DRAWNULL),COLOR00FFFF,LINETHICK4,POINTDOT;
今进场价:REF(明进场价,1),COLORFF0000,NODRAW;
短买:VAR19,COLOR33AACC,NODRAW;
STICKLINE((多方 > 空方),空方,多方, 0, 0)COLOR00FFFF;
STICKLINE((空方 > 多方),多方,空方, 0, 0)COLORFF0000;
STICKLINE(操作线<A,HIGH,LOW,0,0),COLORCCCCCC;
STICKLINE(操作线<A,OPEN,CLOSE,1,0),COLORCCCCCC;
品红离场:VAR1A,COLORFF99FF,NODRAW;
DRAWTEXT(CROSS(空方,多方),多方 * 1.03,'↓卖')COLOR00FF00;
DRAWTEXT(CROSS(多方,空方),空方 * 0.98,'↑买')COLOR0000FF;
WWWCHNMONEYCOM:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
STICKLINE(CROSS(A,操作线),HIGH,LOW,0,0),COLOR00FF00;
STICKLINE(CROSS(A,操作线),OPEN,CLOSE,1,0),COLOR00FF00;
DRAWICON(CROSS(A,操作线),HIGH+0.01,2),COLOR00FF00;
DRAWICON(((REF(A21,1)=(0-2)) AND (A21=0)),LOW,5);
DRAWICON(((REF(A1E,1)>0) AND (A1E=0)),HIGH,6);




2、百万绝品公式,杨百万公式组 红箭头是买入信号

这个指标是杨百万公式组的的绝品公式,
公式的用法:( 顶尖财经 股民学院: http://www.58188.com )
出现黄柱图标,很多可能就是妖股,
出现红箭头,一般是买入信号,
可靠信比较强。
 

{百万绝品F}

VAR1:=(DATE>901224) ;

趋势线:(VAR1)*(((3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-50)*(1.032)+50),COLOR586FDE;

VAR0:=((2)*(CLOSE)+HIGH+LOW+OPEN)/(5);

VAR2:=LLV(LOW,34);

VAR3:=HHV(HIGH,34);

SK:(EMA(((VAR0-VAR2)/(VAR3-VAR2))*(100),13))*(VAR1),COLORFF00FF;

SD:(EMA(SK,2))*(VAR1),COLOR95ECFF;

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=(VAR1)*(EMA(DIFF,9));

A1:=(((VAR1)*(CLOSE))*(1.236)<MA(CLOSE,60));

A2:=((CLOSE)/(REF(CLOSE,1))>1.0213);

A3:=((HIGH-CLOSE)*(1.36)<=CLOSE-OPEN);

A41:=((MA(CLOSE,120)-CLOSE)/(CLOSE))*(100);

A51:=ABS(DIFF-DEA);

A61:=(STD(CLOSE,90))*(10);

A8:=COUNT((((REF(CLOSE,15)-CLOSE)/(CLOSE))*(100)>45),5);

买91:((VAR1)*(A1 AND A2 AND A3 AND (A61<25) AND (CLOSE<8) AND (A41<114) AND (A51<=0.23)))*(35),COLORDD22DD,STICK;

A0:=SLOPE(CLOSE,40);

B1:=COUNT(((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1))<(-0.09799999)),90);

A4:=((MA(CLOSE,120)-CLOSE)/(CLOSE))*(100);

A6:=((VAR1)*(STD(CLOSE,63)))*(10);

VAR20:=(VAR1)*(MA(CLOSE,76)-(MA(CLOSE,13))/(3));

SQ:=(VAR1)*(MA((CLOSE-VAR20)/(VAR20),1));

买87:(VAR1)*(IF((CROSS(SQ,(-0.008)) AND (A0>(-0.61799997)) AND (A4<114) AND (A6<23.6) AND (B1<8) AND ((LOW)/(REF(HIGH,1))<1.145) OR (REF(SQ,2)=LLV(SQ,20)) AND (REF(SQ,2)<0.04199999) AND (B1<8) AND (REF(SQ,2)<REF(SQ,1)) AND NOT((REF(LOW,1)>REF(HIGH,2)) AND (LOW>REF(HIGH,1))) AND (SQ>(-0.368)) AND (CLOSE>REF(CLOSE,1))),68,0)),COLOR00FFFF,STICK;

TYP:=((VAR1)*(HIGH+LOW+CLOSE))/(3);

CCI:=(TYP-MA(TYP,14))/((0.015)*(AVEDEV(TYP,14)));

VAR01:=(((CLOSE)/(MA(CLOSE,40)))*(100)<76);

VAR02:=(((CLOSE)/(MA(CLOSE,60)))*(100)<74);

VAR03:=(HIGH>(LOW)*(1.051));

VAR04:=VAR03 AND (COUNT(VAR03,5)>1);

买94:((VAR1)*(VAR04 AND (VAR01 OR VAR02) AND ((MA(CLOSE,27))/(CLOSE)>1.169) AND ((MA(CLOSE,17))/(CLOSE)>1.158) AND (CLOSE<MA(CLOSE,120)) AND (MA(CLOSE,60)<MA(CLOSE,120)) AND (MA(CLOSE,60)>MA(CLOSE,30)) AND (CCI>(-210)) AND (MA(VOL,60)>MA(VOL,30)) AND ((CLOSE>OPEN) OR (CLOSE<OPEN)) AND ((OPEN-REF(CLOSE,1))/(REF(CLOSE,1))>(-0.07))))*(52),COLOR2222FF,STICK;

MA1:=MA(CLOSE,5);

MA2:=MA(CLOSE,10);

MA3:=(VAR1)*(MA(CLOSE,20));

MA4:=MA(CLOSE,30);

MA5:=MA(CLOSE,60);

MA6:=MA(CLOSE,150);

MA7:=MA(CLOSE,250);

FS:=(((VAR1)*(VOL))/(CAPITAL))*(100);

CJ:=((CLOSE-MA7)/(MA7))*(100);

ZF:=((VAR1)*((CLOSE)/(REF(CLOSE,1))-1))*(100);

VAR11:=(VAR1)*(PWINNER(1,CLOSE));

VAR333:=IF((VAR1>0.75) AND (VAR1<0.90100002),0.61799997,1);

牛97:IF((MA1>MA2) AND (MA2>MA3) AND (MA3>MA4) AND (MA3>MA5) AND (MA6>MA7) AND ((VAR11>=0.89999997) OR (VAR11>0.75999999) AND (VAR11<0.90100002) AND (ZF>5) AND (FS>5)) AND (ZF>1.8) AND (CJ<40) AND (CLOSE>3) AND ((CLOSE-MA5)/(MA5)<0.25) AND (FS<=6) AND ((VAR3)*(FS)>=1) AND (CLOSE<18.5),76,0),COLORRED,STICK,LINETHICK3;

短多空:=((VAR1)*(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24)))/(4);

中多空:=(MA(CLOSE,48)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/(4);

长多空:=((VAR1)*(MA(CLOSE,12)+MA(CLOSE,24)+MA(CLOSE,48)+MA(CLOSE,96)))/(4);

年线:=(VAR1)*(MA(CLOSE,250));

九线:=(VAR1)*(MA(CLOSE,125));

牛:IF((SD>18) AND (SK<75) AND CROSS(短多空,中多空) AND ((长多空-年线)/(年线)<0.1613) AND (REF(SK,3)<SK) AND (REF(长多空,1)<长多空),95,0),COLOR33AADD,STICK;

VAR111:=((CLOSE)/(MA(CLOSE,3))>=1.05) AND (CLOSE=HHV(CLOSE,3)) AND ((MA(VOL,2))/(MA(VOL,40))>=3) AND (MA(VOL,2)=HHV(MA(VOL,2),3)) AND (VOL>REF(VOL,1)) AND (CLOSE>REF(CLOSE,1));

VAR112:=REF(CLOSE,1);

VAR113:=((SMA(MAX(CLOSE-VAR112,0),5,1))/(SMA(ABS(CLOSE-VAR112),5,1)))*(100);

VAR114:=((VAR1)*(COUNT((VAR113<25),20))>=1);

VAR115:=((HIGH-LOW)/(HIGH))*(100)+((CLOSE-VAR112)/(VAR112))*(100);

VAR116:=EMA(MA(VAR115,41),6);

VAR117:=(VAR116>(LLV(VAR116,6))*(1.02)) AND (REF(VAR116,1)<(REF(LLV(VAR116,6),1))*(1.02)) AND (LLV(VAR116,29)=LLV(VAR116,6));

VAR118:=((VAR1)*((LLV(LOW,6)=LLV(LOW,41)) AND (LLV(LOW,6)<((HHV(LOW,41))*(100-29))/(100))))*(VAR1);

VAR119:=(HIGH>(LOW)*(1.033));

从此反转:((VAR1)*(((VAR118>0) AND VAR119)*(16)+81.5))*(VAR1),COLORFF99FF;

买入:(IF(CROSS(趋势线,21),50,18.5))*(VAR1),COLORRED;

卖出:(IF(CROSS(87,趋势线),50,81.5))*(VAR1),COLORFFF000;

DRAWTEXT((VAR118>0) AND VAR119,88,'↑'),COLOR00FF00;

VAR4:=IF(CROSS(SK,SD),25,18.5);

VAR5:=IF(CROSS(SD,SK),75,81.5);

卖线:(VAR5)*(VAR1),COLORFFF000;

买线:(VAR4)*(VAR1),COLOR33FF66;

{((SQ<0.05999999))*((-10))+81.5,COLOR44FF55;

底:(((-SQRT(SQRT(FLOOR(SQRT((MA(((1)/(WINNER(CLOSE)))*(100),4))/(10000)))))))*(5))*(VAR1),COLOR4455EE;

STICKLINE((底<(-2)),0,底,1.5,1),COLOR2222FF;

VAR32:=(DATE=1040428);};




3、操盘机器人

任何指标,起的作用只不过是一种辅助
心理分析过程( 顶尖财经 股民学院: http://www.58188.com )
趋势分析过程
盘后分析过程

{操盘机器人}
EMA13:EMA(C,5),COLORWHITE; {13-21-34-60}
EMA21:EMA(C,13),COLORYELLOW; 
EMA34:EMA(C,21),COLORFF00FF;
EMA60:MA(C,60),COLORFFCC66; 
{大阴线:大跌超2.3}
C2:=REF(C,1);
BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0){ OR IF((H-L)*100/REF(C,1)>5,1,0)};{第二个条件开盘价过高掉下来}
BG2:=IF((H-L)*100/C2>=3.58,1,0);
BB1:=L<REF(L,1);
{卖点信号}
SELL1:=BG AND BB1 ;
{大阳线:升幅超2.64}
BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);{第二个条件开盘价太低升上来}
STICKLINE(BR,O,C,3,0),COLORRED;
{以下条件记住最近一次卖出点}
DAY1:=BARSLAST(SELL1);
JIA1:=REF(O,DAY1);
JIA2:=REF(O,1);
BB4:=C>JIA2;
BB2:=H>JIA1;
{买入信号}
BUY1:=BR AND BB2 AND BB4;
{记住最后一次买点}
DAY2:=BARSLAST(BUY1);
{买卖谁先}
S1:=DAY1<DAY2;
B1:=DAY2<DAY1;
{画出卖出信号}
{DRAWTEXT(S1,H*1.05,'S'),COLORGREEN;}
STICKLINE(S1,O,C,3,0),COLORGREEN;
{画出买入信号}
{DRAWTEXT(B1,L-0.2,'B'),COLORRED;}
STICKLINE(B1,H,L,0.3,0),COLORRED;
STICKLINE(B1,O,C,3,1),LINETHICK2,COLORRED;
{其它补充1:买点}
AA2:=AMOUNT/VOL;
BB3:=L<AA2*0.9;
CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD2:=L<MA(C,6)*0.921;
DD1:=L<MA(C,5)*0.921;
EE2:=VOL<MA(V,5)*1.5;
FF2:=BB3 AND CC2 AND DD2 AND EE2;
老鼠仓:=BB3 AND CC2 AND DD1 AND EE2,LINETHICK0,COLOR0099FF;
DRAWTEXT(老鼠仓,L*0.97,'老鼠仓'),COLOR0099FF;
{DRAWTEXT(FF2,L*0.99,'买点'),COLOR00FFFF;}
STICKLINE(FF2,H,L,0.3,0),COLOR00FFFF;
{STICKLINE(FF2,O,C,3,1),LINETHICK2,COLOR00FFFF;}
{检查买点是否成立}
B4:=BARSLAST(FF2);{底点日期}
E4:=B4<5;{5日内的线}
F4:=E4 AND C>REF(C,1);
STICKLINE(F4,H,L,0.3,0),COLOR00FFFF;
{其它补充2:卖点}
A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
A3:=H>MA(C,5)*1.12;
AA:= A2 AND A3;
DRAWTEXT(AA,H*1.05,'卖点'),COLORFF0000;
STICKLINE(AA,H,L,0.3,0),COLORFF0000;
{STICKLINE(AA,H,L,3,0),COLORFF0000;};
{补充阳光买点}
VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;
CC:=CROSS(VAR1,VAR2);
CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1) ;
DRAWICON(CCC,L*0.99,1);
STICKLINE(CC,H,L,0.3,0),COLORRED;
STICKLINE(CC,O,C,3,1),LINETHICK2,COLORRED;
{加强买点后续升势}
CF1:=BARSLAST(CC);{买点日期}
CF2:=CF1<3;{5日内的线}
CF3:=CF2 AND C>REF(C,1);
STICKLINE(CF3,O,C,3,0),COLOR00FFFF;
CD:=CROSS(VAR2,VAR1);
STICKLINE(CD,H,L,0.3,0),COLORYELLOW;
STICKLINE(CD,O,C,3,1),LINETHICK2,COLORYELLOW;
DRAWTEXT(CD,H*1.01,'准备'),COLORYELLOW;
DRAWTEXT(CC,L*0.98,'买'),COLORFF00FF;{输出粉红色的买字};
{牛窝}
VAR1A:=LLV(LOW,21);
VAR2A:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 100),5);
AK:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.95),'○牛窝'),COLORYELLOW;
{主力成本及短期支撑}
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
主力成本:EMA(X,13),LINETHICK1,COLORLIGRAY;
短期支撑:LLV(HIGH,30),LINETHICK2,COLORFFCC00;
{大胆博、加仓、小心变盘、逃顶}
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.02,'逃顶'),COLORYELLOW;
{主力进场}
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1);
主力出现:DRAWICON(CROSS(VAR11,VAR12) AND (VAR11<40),L*0.98,1);
{黑马}
A1A:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;
A5A:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
DRAWTEXT(CROSS(A1A,EMA(A1A,5))AND EMA(A1A,5)<A5A,L*0.98,'黑马'),COLORYELLOW;
{波段上行和买入};
多:EMA(C,3),COLORYELLOW;
空:EMA(C,5),COLOR00FF00;
均衡:EMA(空,5),COLORWHITE,;
VVARF1:=COUNT(CROSS(多,均衡),2)=1;
VVARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VVARF1 AND VVARF2,2);
DRAWTEXT(ZAI,均衡*0.985,' ▲'),COLORRED;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORRED;
VVARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100; 
VVARB:=EMA(0.667*REF(VVARA,1)+0.333*VVARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VVARA>=VVARB AND VVARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');
VVARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VVARR1),HIGH,2);
DRAWTEXT(CROSS(82,VVARR1),HIGH,''),COLORYELLOW;
VVAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VVAR2:=REF(VVAR1,1);
VVAR3:=SMA(MAX(VVAR1-VVAR2,0),10,1)/SMA(ABS(VVAR1-VVAR2),10,1)*100;
HY3:=IF(COUNT(VVAR3<20,5)>=1 AND COUNT(VVAR1=LLV(VVAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW,' 注意买入'),COLORRED;

上一篇:通达信公式下载:埋伏起飞组合股市利器,康熙把局主图和大明真图副图

下一篇:通达信源码:散户阶段底超跌反弹,坐地炮,K线组合